How to fix the error when upgrading SMF to 1.1.16


Screen shot 2013-08-14 at 1.13.38 PMMany Simple Machines users have reported an error trying to upgrade SMF from 1.1.15 to 1.1.16. The error they see is:

“The package you are trying to download or install is either corrupt or not compatible with this version of SMF.”

One of the SMF developers posted a download that should update your forum correctly. First download the file here:

http://www.simplemachines.org/community/index.php?action=dlattach;topic=463108.0;attach=193106

(to download, you need to register a free account at the SMF Community, if you don’t already have one)

Make sure your forum files and database are backed up (this is already done nightly at OLI).

Then login to your forum and go to Admin -> Packages (on the left under Main) -> Download Package (tab near middle) -> and click “Browse” next to Package to Upload and select the file you downloaded from Simplemachines.com called smf_patch_1.0.22_1.1.16(2).zip

Then click “Apply Mod” on the lower right of the page.

Make sure the tests look good and if so click “Install Now” — then when you refresh your forum homepage you should see the new version 1.1.16 listed in the footer.

This is the only case we know of where such a manual upgrade is required, so after this you should be good to go until upgraded to the latest version.

Share Button